Exportación de archivos IDF
Puedes utilizar DesignBuilder para generar archivos idf de EnergyPlus para utilizarlos en entornos de simulación externos como EP-Launch. Hay 3 procedimientos alternativos:
- Desde la opción Archivo > Exportar del menú (método preferido).
- Copiando el archivo intermedio in.idf de la carpeta de EnergyPlus.
- Herramientas > Mostrar el script de entrada de simulación desde las pantallas de simulación o de diseño de calefacción/refrigeración.
DesignBuilder generará automáticamente archivos IDF compatibles con la versión de destino de EnergyPlus configurada en el cuadro de diálogo Opciones del programa.
Nota: Es importante establecer la versión de EnergyPlus que vayas a utilizar antes de exportar los datos IDF..
1. Opción Archivo > Exportar del menú (recomendada)
- Abre tu archivo de modelo dsb de DesignBuilder.
- En la pestaña EnergyPlus del cuadro de diálogo Opciones del programa, asegúrate de seleccionar la versión ejecutable DOE recomendada de la versión más reciente de EnergyPlus disponible en la lista, por ejemplo «Version 7.0.0.036 (Recommended DOE)».
- Asegúrate de haber descargado e instalado esa versión de EnergyPlus desde el sitio web del DOE.
- Asegúrate de estar en el nivel de edificio o en uno inferior.
- Haz clic en la opción Archivo > Exportar > Exportar archivo de entrada de EnergyPlus o DBSim > Simulación del menú.
2. Copiar in.idf de la carpeta de EnergyPlus
Una forma alternativa de generar archivos IDF es utilizar el archivo intermedio in.idf de la carpeta de EnergyPlus que se genera antes de cada simulación de EnergyPlus en DesignBuilder. Debes copiar este archivo con otro nombre o en otra ubicación antes de utilizarlo.
Importante: en general no debes modificar in.idf directamente, ya que se sobrescribirá antes de la siguiente simulación de EnergyPlus en DesignBuilder y perderás los cambios.
3. Opción Herramientas > Mostrar del menú
Puedes ver el script de datos de entrada utilizado para calcular estos resultados seleccionando la opción Herramientas > Mostrar el script de entrada de simulación del menú. Si no tienes instalado el editor IDF de EnergyPlus, debes asociar la extensión de archivo .idf a un editor de texto para que esta opción funcione.
Nota: esto muestra el script almacenado con el modelo justo antes de la simulación, no el archivo in.idf guardado en la carpeta de EnergyPlus.
La geometría se exporta a IDF mediante los siguientes tipos de objeto IDF:
-
Superficies de edificio como BuildingSurface:Detailed
-
Ventanas como FenestrationSurface:Detailed
-
Sombreado local como Shading:Building:Detailed o Shading:Site:Detailed
-
Superficies de contexto del sitio (bloques de componente y bloques de montaje ) como Shading:Site:Detailed o Shading:Building:Detailed
Volver a cargar archivos de resultados ESO en DesignBuilder
Siempre que no hayas cambiado los nombres de zonas y superficies de los datos IDF, puedes volver a cargar los archivos de resultados ESO generados a partir de los datos modificados en DesignBuilder para visualizarlos y analizarlos.
Consejo: Si ya conoces la estructura de datos de EnergyPlus, quizá prefieras editar los datos IDF de DesignBuilder con un editor de texto, porque muestra más claramente los comentarios incluidos para ayudar a relacionar los datos IDF con el modelo de DesignBuilder.