Procesador de archivos de datos climáticos
Edición en español con correcciones revisadas · Estado de revisión

Procesador de archivos de datos climáticos

Se accede desde el menú Herramientas .

 

 

El Procesador de archivos de datos climáticos puede utilizarse para convertir datos climáticos horarios entre diversos formatos de archivo. Internamente utiliza el EnergyPlus Weather Converter. Puede utilizarse por varios motivos, entre ellos:

 

  • Convertir datos epw de EnergyPlus para que los resultados diarios, horarios y subhorarios de DesignBuilder coincidan con el día de la semana (establecer el año en 2002).
  • Convertir datos climáticos de otros formatos a epw para utilizarlos en DesignBuilder.
  • Generar conjuntos de datos climáticos modificados para representar casos de diseño extremos, como escenarios de cambio climático.
  • Crear archivos de informe adicionales a partir de archivos .epw, incluidos .stat (estadísticas), .ddy (datos de diseño) y .audit.
  • Corregir puntos de datos no válidos que estén fuera del intervalo habitual.

 

Consejo: La ayuda de Climate Analytics incluye una página que describe diversas formas de ver y editar archivos meteorológicos de EnergyPlus.

En particular, Rocky Mountain Institute ofrece una herramienta gratuita para editar y convertir datos climáticos horarios .epw llamada Elements. Puede resultar más cómoda para editar archivos epw que el procesador integrado de DesignBuilder. Ofrece un entorno de hoja de cálculo que permite editar valores individuales o pegar rangos de datos desde una hoja de cálculo externa. Para más información consulta la página de descargas de Elements.

Para editar o convertir uno o varios archivos:

 

  1. En la pestaña Datos de entrada selecciona la carpeta que contiene los archivos mediante el cuadro de exploración situado en la parte superior izquierda del cuadro. Todos los archivos climáticos pertinentes se cargan en la tabla.
  2. Marca la casilla situada junto a cada archivo que se debe convertir.
  3. Comprueba que se han establecido las opciones correctas en la pestaña Opciones.
  4. Pulsa el botón Convertir para iniciar el proceso.

 

Los archivos convertidos se guardan en la carpeta de datos climáticos. Puedes acceder a ellos haciendo clic en la pestaña Editar/Revisar .

Datos de entrada

En la pestaña Datos de entrada puedes seleccionar los archivos de origen que se van a convertir marcando sus casillas.

Consejo: Utiliza los botones Seleccionar todo y No seleccionar ninguno de la parte inferior del cuadro para seleccionar o deseleccionar rápidamente varios elementos.

Haz clic en el botón Convertir para iniciar la conversión.

Opciones

En la pestaña Opciones puedes seleccionar varias opciones que se utilizarán durante la conversión.

Formato de archivo de salida

Los formatos admitidos son:

 

  • Archivos de datos EnergyPlus (.epw)
  • Archivos EnergyPlus de valores separados por comas (.csv)
  • Archivos de datos TMY2 (.tmy2 o tm2)
  • Archivos de datos TMY (.tmy)
  •  Archivos de datos IWEC (.iwec o iwc)
  • Archivos de datos Samson (.samson o dat)
  • Archivos de datos WYEC2 (.wyec2 o wy2)
  • Archivos con formato DOE-2 (.fmt o txt)
  • Archivos con formato ESP-r (.esp-r o clm)
  • Archivos con formato ASCII BLAST (.blast o asc)
  • Formato personalizado definido mediante un archivo .def

 

Las extensiones necesarias se muestran entre paréntesis.  

Corrección de errores

Corregir datos fuera de rango

Puedes corregir automáticamente los valores que estén fuera del intervalo habitual del convertidor de EnergyPlus marcando la casilla Corregir datos fuera de rango .

 

El formato de archivo epw incluye valores mínimos y máximos para varios campos. El convertidor meteorológico puede ignorarlos y limitarse a notificarlos o intentar corregirlos con valores adecuados. Si se marca esta opción, el procesador intentará corregir los datos; si no se marca, no los corregirá, aunque notificará los valores fuera de rango que encuentre.

Notificación de errores

Según el control de calidad y la precisión de los datos climáticos, los cambios de una hora a otra en algunos valores pueden hacer que los datos de ese período resulten sospechosos. La selección de notificación de errores permite controlar parcialmente cómo se notifican estos valores atípicos de los datos de origen.

Nota: estos datos no se «corrigen»; el programa solo los notifica en el archivo de informe de auditoría.

Las opciones disponibles son:

 

  • Usar el valor de disparo calculado como disparador principal

  • Usar 5°C

  • Usar 10°C

  • Usar 15°C

  • Ignorar valor calculado

 

Aunque solo puede seleccionarse un valor de «disparo», los valores consecutivos de temperatura de bulbo seco, temperatura de punto de rocío y velocidad del viento se notifican utilizando valores calculados adecuados. Para el punto de rocío y el viento se utiliza un valor calculado a partir de la media de todo el período de datos y la desviación estándar respecto a ella, obtenido heurísticamente.

 

Un extracto del archivo de auditoría ilustra esto:

 

Average Delta DB Change = 0.78°C ; Std Dev = 0.83°C

Average Delta DP Change = 0.68°C ; Std Dev = 0.78°C

Average Delta Relative Humidity Change = 4.02% ; Std Dev = 4.22%

Average Delta Wind Speed Change = 0.91m/s ; Std Dev = 0.88m/s

Hourly Dry Bulb temperature change trigger = minimum of 12.13°C and 10.°C

12.13°C = valor de activación calculado a partir del cambio medio de temperatura de bulbo seco y la desviación estándar indicados arriba

10.°C = valor de activación establecido por el usuario

 

Aquí el valor de disparo DB calculado sería 12.13°C, pero el seleccionado por el usuario es 10°C, por lo que se notificarán los cambios horarios de temperatura de bulbo seco iguales o superiores a 10°C.

 

Si la opción Ignorar valor calculado está seleccionada, el valor de disparo definido por el usuario se utiliza directamente para la temperatura de bulbo seco.

 

Por ejemplo, podrías ver un informe como este:

 

Delta DB/DP Range Triggered for Apr 30

Change in DB = 11.60°C, Hour = 14

 

Este detalle permite editar manualmente los datos de entrada, si se desea.

Cambiar nombre de archivo

Puedes aplicar la convención estándar utilizada por DesignBuilder para cambiar el nombre del archivo de salida. Si seleccionas esta opción, se nombrará siguiendo la convención Country_Location_Source.

Modificar

Puedes realizar los siguientes cambios en los datos climáticos.

Fijar año

Puedes fijar el año en 2002. Es un paso recomendado cuando deseas ver resultados diarios, horarios o subhorarios de EnergyPlus en DesignBuilder o en el Visor de resultados. Los motivos se explican en la página Añadir datos meteorológicos horarios .

Modificar clima

Puedes establecer el número de grados-día de calefacción o refrigeración, o añadir una diferencia fija a los valores de temperatura exterior de bulbo seco de los datos climáticos. Si seleccionas la opción de grados-día, DesignBuilder suma o resta la misma diferencia de temperatura a todos los valores de temperatura exterior de bulbo seco para obtener los grados-día de calefacción y refrigeración solicitados con la temperatura base indicada.

Editar/Revisar

Puedes ver todos los archivos de la carpeta actual de datos meteorológicos horarios en esta pestaña. Puedes abrir cualquiera para verlo o editarlo haciendo clic en el enlace Abrir archivo seleccionado del panel de información o haciendo doble clic sobre él.

Conversión desde otros formatos

Si dispones de datos meteorológicos horarios en un formato no admitido por el traductor de datos de DesignBuilder, hay 2 maneras de utilizarlos para generar un archivo meteorológico equivalente en formato epw.

 

  1. Utiliza la opción personalizada en la que el formato de los datos de origen se define en un archivo .def situado en la misma carpeta y con el mismo nombre base. Por ejemplo, si el archivo de entrada se llama London.dat, el archivo .def debe llamarse London.def y guardarse en la misma carpeta que London.dat. Consulta la ayuda de EnergyPlus para obtener descripciones detalladas del formato de archivo .def.

  2. La segunda opción consiste en utilizar un archivo epw existente como plantilla y copiar las columnas de datos desde el archivo de origen mediante el formato de hoja de cálculo csv.

 

El resto de esta sección detalla el segundo método.

 

Para convertir datos meteorológicos desde cualquier formato, sigue estas instrucciones. Como punto de partida debes tener los datos principales requeridos por EnergyPlus en un archivo csv o una hoja de cálculo. Los datos necesarios son:

 

  • Temperatura del aire
  • Temperatura de punto de rocío
  • Humedad relativa
  • Presión atmosférica
  • Radiación solar global horizontal
  • Radiación solar difusa horizontal
  • Radiación normal directa

  • Velocidad del viento
  • Dirección del viento
  • Nubosidad

 

Si falta alguno de los parámetros anteriores y no sabes cómo obtenerlo, puedes considerar el traductor meteorológico personalizado de EnergyPlus, que incluye funciones para obtener algunos parámetros a partir de otros datos equivalentes. Por ejemplo, la radiación normal directa puede obtenerse a partir de la posición solar y las radiaciones global y difusa horizontales conocidas.

 

Si dispones de todos los datos necesarios en columnas de un archivo csv, puedes continuar. El proceso es el siguiente:

 

  1. Para empezar, genera una plantilla en formato csv para una ubicación similar. Utiliza la herramienta de conversión de datos climáticos y selecciona la opción de salida «EnergyPlus archivos de valores separados por comas» en la pestaña Opciones.
  2. Carga en una hoja de cálculo el archivo csv creado en el paso 1 para utilizarlo como plantilla.
  3. Carga los nuevos datos en otra hoja de cálculo.
  4. Copia y pega los datos columna por columna desde la hoja de cálculo de los nuevos datos a las columnas equivalentes de la plantilla. Puedes introducir un valor indicador de dato ausente en los lugares donde EnergyPlus no utiliza los datos. Este indicador es distinto para cada campo y puedes encontrar los detalles en la Auxiliary Programs Guide.
  5. Comprueba que los datos de cabecera de la parte superior de la hoja de cálculo de la plantilla son correctos.
  6. Asegúrate de que el año esté establecido en 2002 en todas las filas.
  7. Guarda la plantilla como archivo csv.
  8. Utiliza el traductor de archivos climáticos para convertir el archivo csv de la plantilla al formato epw.
  9. Cambia el nombre del archivo epw según sea necesario.
  10. Comprueba que los datos se han copiado correctamente cargando el archivo en DesignBuilder y haciendo clic en la pestaña Simulación a nivel de emplazamiento. Primero tendrás que configurar y seleccionar un componente de datos meteorológicos horarios que haga referencia al nuevo archivo epw.
  11. Comprueba cuidadosamente que los datos obtenidos de simulaciones que utilizan el nuevo archivo meteorológico tienen sentido. Presta especial atención a la radiación solar. Por ejemplo, puedes comprobar la radiación solar incidente horaria sobre varias superficies de un modelo.

Nota: Si tu configuración regional difiere de la de UK/US, podrías encontrar problemas; por ejemplo, que la hoja de cálculo cambie la línea DataPeriods de 1/1, 12/31 a 01-Jan. Tendrías que editarla manualmente antes del paso 7.

Nota: Normalmente no se considera adecuado utilizar datos de un año concreto para un análisis energético. Consulta este documento sobre selección de datos meteorológicos: Drury B. Crawley. 1998. Which Weather Data Should You Use for Energy Simulations of Commercial Buildings? en ASHRAE Transactions, pp. 498-515, Vol. 104, Pt. 2. Atlanta: ASHRAE.